Guix + Lem - has anyone installed/trialed it?

Hey Gang,

I am currently trialing out Lem (Common Lisp Emacs-like editor) on my Guix SD but am running into some issues. I installed via the following Lem Guix Pacakge recipe, i.e.

$ guix package -f path/to/lem-guix-packaging/package.scm

For the most part everything works well, except when trialing out the version control, i.e. lem/legit via (require :lem/legit) I get an error about a micros compilation error, I get the same error when trying to just (require :micros).

Looking at the Guix recipe, it appears micros is defined and should be installed and compiled with Lem when I performed guix package ....

At this point I am unsure how to resolve if this is an error with the recipe or my own configuration or Lem itself…So I am just putting out a call to help for anyone who has tried Lem on Guix and can perhaps can guide me to what I am doing wrong.

PS: I did try asking on their Discord forum, but to no avail… Most aren’t Guix users from my estimation.

Also, I am currently using Guix Home for my configuration setup for all of my non-system essential packages (just sbcl/StumpWM defined there - if that matters)

Thanks!

1 Like

Added Guix, lisp

I wanted to add to this request for help some additional questions. Does anyone know how to get a hybrid setup between Guix & Quicklisp?

I have come to the conclusion that the Common Lisp ecosystem is still quite small for Common Lisp packages in Guix and in the interim would like to still functionally use Guix for Common Lisp development until I can be able to perhaps help push upstream Guix package recipes for the things I will be using.

Again - greatly appreciate any help!