Guix install problems on ThinkPad X13 AMD

I’m currently fighting a “new” ThinkPad.

I used the nonguix release and put it on a USB stick.
followed my own notes that worked for my ThinkPad x280.

Fist try of guix system init didn’t get grubx64.efi installed. I created /mnt/boot/efi/EFI/Guix/ and the second try finished but somehow the UEFI will not boot from the installed system as GRUB doesn’t appears to get loaded at all.

I tried to retraced my steps and now guix system init fails building .*-info-dir.drv and the .*-info-dir.drv.gz is empty.

Any ideas or should I start over with the img from Release Guix Installer - 202308290335 · SystemCrafters/guix-installer · GitHub ?

Recently did an install on new T14 and it was successful with the released NonGuix image. It’s old, but I couldn’t get the latest build to successfully install, so I just used the old and and did the glorious 1 hour guix pull…

I did try again while booted with the “systemcrafter.iso” and guix pull failed a couple of times but last run worked - maybe bad network.

Now guix system init is running and I hope it will finish without errors.


Guix has had a lot of infrastructure problems recently. If at first you don’t succeed try again tomorrow.

Thanks, still tried yesterday and got the error about info-dir and while looking it the .gz file there was one line about something-wget-someting.gz “unexpected end of file” or something like this.

Need to have a more precise look in the evening, as I can’t access the machine from work.